[Postgres-xl-general] Recursive CTE on replicated table?

Pavan Deolasee pavan.deolasee at gmail.com
Wed Sep 24 05:38:25 PDT 2014


On Wed, Sep 24, 2014 at 8:43 AM, Aaron Jackson <ajackson at revionics.com>
wrote:

>      My colleague wrote a function that employed a recursive CTE.  It
> failed indicating that "WITH RECURSIVE currently not supported on
> distributed tables" - I read that as doesn't work on distributed tables but
> should work on replicated tables.  So we replicated the table and found we
> got the same error.
>
> I could be wrong, but looking at the code it seems  WITH RECURSIVE support
is quite limited in XL right now. That error message is also misleading
because WITH RECURSIVE seems to be blocked for subqueries, function scans,
value scan etc. In fact, I wonder if recursive queries work at all right
now. WITH queries (i.e. without recursion) should work for much better
though.


>  If true, it means that recursive CTEs will not work on ANY tables since
> a table must by definition be distributed (even if by replication).  Are we
> missing something here?
>
Like I said, the error message is misleading because even for subqueries,
the same error message is printed, We should at least fix the error message
in the next release.

Thanks,
Pavan
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.postgres-xl.org/private.cgi/postgres-xl-general-postgres-xl.org/attachments/20140924/5ce196e9/attachment.htm>


More information about the postgres-xl-general mailing list